Gusi steuert fern

Alles was kleiner ist als gleich ein ganzes Heimkino ;)

Re: Gusi steuert fern

Beitragvon pebo_muc » Montag 9. Oktober 2017, 07:36

Ich hatte so etwas ähnliches mit Wlan....den konnte man in den Sleep-Modus versetzen....dann ging's. Und beim 433 modul funktioniert es unproblematisch, wenn man den vom Strom trennt...war bei meinem z.B. sogar notwendig, weil das Teil permanent gesendet hat, wenn Strom an war....zwar nur ein Rauschen, aber das hat andere 433mhz Sender gestört wie z.B. den Autoschlüssel :lol: Die haben bei mir vor der Türe dann nicht mehr funktioniert :rolleyes:
Grüße...
....Peter

Kellerkino: 5mx3,50m, Sony HW65ES, LW celexon 240 x 135 cm , Sony BDP-S6700, PS3, PS4, PC, Denon AVR-X4100W, 7.3 Boxensetup (3xNuBox 383, 4xNubox 313,SUBS: 2 Mivoc-Subs an t.amp S-150MK II + Denon Karat AS 200 SC)+Podest mit Buttkicker
Benutzeravatar
pebo_muc
 
Beiträge: 1086
Bilder: 153
Registriert: Montag 4. Mai 2015, 14:14

Re: Gusi steuert fern

Beitragvon gusi » Montag 9. Oktober 2017, 17:05

Hallöchen!
pebo_muc hat geschrieben:Ich hatte so etwas ähnliches mit Wlan....den konnte man in den Sleep-Modus versetzen....dann ging's. Und beim 433 modul funktioniert es unproblematisch, wenn man den vom Strom trennt...war bei meinem z.B. sogar notwendig, weil das Teil permanent gesendet hat, wenn Strom an war....zwar nur ein Rauschen, aber das hat andere 433mhz Sender gestört wie z.B. den Autoschlüssel :lol: Die haben bei mir vor der Türe dann nicht mehr funktioniert :rolleyes:

Verstehe ich das richtig, dass Du jetzt Dein Auto ohne Schlüssel aufsperren kannst :grin: ?

Sleep also, hmm ... muss schauen, ob das ginge.

Tante google meint, es gibt da einen Fehler bei manchen W5100 Shields. Genau so eines habe ich :) . Da wird der "SPI Enable" Pin nicht richtig gesetzt. Aber man kann das mit ein bissl Lötzinn und einer ruhigen Hand fixen :) . Ich werde das am kommenden Wochenende mal probieren.

Ciao,
Christian.
Benutzeravatar
gusi
 
Beiträge: 1035
Bilder: 5
Registriert: Donnerstag 19. Mai 2011, 19:06
Wohnort: Linz/Österreich

Re: Gusi steuert fern

Beitragvon gusi » Sonntag 15. Oktober 2017, 16:59

Hallöchen!

Ich hatte gestern ein wenig Zeit und da hab ich mich mal wieder mit meiner Steuerung gespielt. Zunächst hab ich mal das umgesetzt, worauf mich Tante Google gebracht hat. Mein Ethernet Shield scheint wirklich das mit dem "Fehler" zu sein. Das SP Interface des CC1101 Chips wird nicht abgedreht wenn es mittels "chip select" Signal ausgeschaltet werden sollte. In dem Artikel, den ich im letzten Beitrag verlinkt habe, wird eine Lösung für das Problem angesprochen.

Ich hab mal mit zittrigen Händen, einem heissen und viel zu großen Lötkolben (fürs SMD Löten ist das Ding nicht geeignet) versucht, ein Kabel an dem SMD Widerstand anzulöten.
img03.png

Da ich keinen 74LVC14 Baustein hier habe, hab ich versucht mit einer Inverterschaltung mit einem Transistor das Signal aus dem chip select zu generieren. Das funktionierte leider nicht so richtig. Ich glaub, der Transistor ist da einfach zu langsam, wenn es ums Ein- und Ausschalten des CC1101 geht. Wenn ich per Programm das Signal einschalte, ein paar Millisekunden warte, dann den CC1101 anspreche und anschliessend wieder ausschalte und wieder ein paar Millisekunden warte, dann funktioniert es. Ohne der Wartezeit geht es jedenfalls nicht.

Ich hab mich daher dazu entschlossen, das Ein- und Ausschalten mit einem separaten Arduino Pin zu steuern. Ich schalte jetzt den CC1101 nur dann aus, wenn ich das Sendemodul brauch. Und sobald das Senden eines Befehls beendet ist, schalte ich den CC1101 wieder ein. Damit funktioniert meine Schaltung jetzt sehr gut.

Der nächste Schritt ist jetzt alle Befehle einzubauen, die ich für die Rollladensteuerung brauche und das Teil in meine Steuerung zu integrieren.

Hier ist noch Bildchen von meinem Testaufbau:
img02.png


Zum Schluss die übliche Warnung: Fortsetzung folgt :) !
Christian.
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
Benutzeravatar
gusi
 
Beiträge: 1035
Bilder: 5
Registriert: Donnerstag 19. Mai 2011, 19:06
Wohnort: Linz/Österreich

Re: Gusi steuert fern

Beitragvon pebo_muc » Sonntag 15. Oktober 2017, 18:06

Sauber Christian!

Das wird was! :clap:
Grüße...
....Peter

Kellerkino: 5mx3,50m, Sony HW65ES, LW celexon 240 x 135 cm , Sony BDP-S6700, PS3, PS4, PC, Denon AVR-X4100W, 7.3 Boxensetup (3xNuBox 383, 4xNubox 313,SUBS: 2 Mivoc-Subs an t.amp S-150MK II + Denon Karat AS 200 SC)+Podest mit Buttkicker
Benutzeravatar
pebo_muc
 
Beiträge: 1086
Bilder: 153
Registriert: Montag 4. Mai 2015, 14:14

Re: Gusi steuert fern

Beitragvon gusi » Montag 16. Oktober 2017, 07:30

pebo_muc hat geschrieben:Sauber Christian!

Das wird was! :clap:

Danke, das will ich doch seeeeehr hoffen :grin:
Benutzeravatar
gusi
 
Beiträge: 1035
Bilder: 5
Registriert: Donnerstag 19. Mai 2011, 19:06
Wohnort: Linz/Österreich

Vorherige

Zurück zu Projekte

Wer ist online?

Mitglieder in diesem Forum: wolfmunich und 2 Gäste